vscode 1.86版本远程ssh不兼容旧服务器问题解决

发布于 2024-02-02  1555 次阅读


最近vscode发布了1.86版本,该版本中,更新了对glibc的要求,需要最低2.28版本,导致各种旧版本的linux发行版(比如最常见的centos 7)都无法用remote-ssh来连接了,会一直控制台报错waiting for server log

根据官方FAQVisual Studio Code Remote Development Frequently Asked Questions,有两种解决办法:

  1. 回退版本到1.85.2,同时永久禁用更新,但这样本地开发的时候也不能使用vscode的最新特性了,不推荐
  2. 使用1.85.2的portable便携绿色版,这样可以和最新的vscode版本共存

我选择了使用便携版来解决,下面简单介绍下流程:

  1. 点击下载链接 下载1.85.2版本的zip包,下载后解压到本地自己选择的目录下
  2. 进入目录,新建data文件夹
  3. 拷贝%APPDATA%\Code目录到data文件夹下,然后重命名为user-data
  4. 拷贝%USERPROFILE%\.vscode\extensions目录到data文件夹下
  5. data文件夹下新建目录tmp

然后给Code.exe创建一个快捷方式,就可以正常使用1.85.2版本了,同时需要把remote-ssh的版本降级到0.107.1,此时就可以正常远程连接服务器